OTRS 8 Patch Level 25

Release Note

OTRS 8 Patch Level 25

September 5, 2022 — OTRS Group, the world’s leading provider of the OTRS service management suite, including the fully managed OTRS solution and the ITIL® 4-compliant IT service management software OTRS::ITSM, today announces the first release of the OTRS 8 patch level 25.

 

Important for Upgrading

Please consult our Update Guide for detailed instructions.

Enhancements

  • Fixed npm audit issues.
  • Fixed wrong log level, and improved explanation about how Sisimai module is used on email bounce detection.
  • Improved customer url handling.
  • Added missing check for required CPAN module List::MoreUtils.
  • Improved error handling during server deployment.
  • Linked Tickets in Ticket and KBA Detail View are shown respecting Ticket::Permission config setting.
  • Improved url handling.
  • Fix CPAN update routine.
  • Improved PostMaster visibility adding log entries on each return statement.

Bug Fixes

  • OTRS Bcrypt does not support externally generated/imported bcrypt passwords. Added new required CPAN module dependency: Digest::Bcrypt.
  • Ticket types in BOL is not translated.
  • ExternalFrontend::Menu###Bottom contains wrong time span in Copyright notice section.
  • Permissions for menu entries and widgets is not consistent.
  • Improved handling of emails with a lot of recipients.
  • S/MIME signing or encryption does not respect x509v3 Key Usage requirements.
  • Restricted KBAs accessible by clicking on link.
  • Survey is not displayed with SSO enabled.
  • Dynamic fields not filled if dynamic ticket templates are used in External Interface.
  • KBA inline images not showing up when inserting into ticket article.
  • Query string gets cut off in Generic Interface.
  • Links with uploaded files are broken in CKEditor.
  • Improved handling of the template toolkit files.
  • Not possible to resize Textarea fields in SysConfig.
  • Organizer item “I am responsible” doesn’t show tickets in queue without RO permissions.
  • Improve endpoint contexts for CustomURL ticket actions.

 

Browser Support

  • JavaScript is required to use OTRS.

We recommend to use the latest version of your browser, because it has the best JavaScript and rendering performance. Dramatical performance varieties between the used browsers can occur with big data or big systems. We are happy to consult you on that matter.

Notes:

  • OTRS 9 will not support Internet Explorer anymore.
  • OTRS 9 will not support Oracle as application database anymore.

 

OTRS Group managed customers who are using product versions that are reaching end of maintenance and support must be updated by our Customer Solution Team by scheduling an individual maintenance appointment in order to continue receiving necessary releases and support. OTRS On-Premise customers must obtain a newer product version by ordering our migration services.

Release Details

  • Release name:
    OTRS 8 Patch Level 25
  • Release date:
    5. September 2022
  • Release type:
    patch level