OTRS Security Advisory 2022-05

Release Note

OTRS Security Advisory 2022-05

Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Please send information regarding vulnerabilities in OTRS to: security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21
  • uid OTRS Security Team <security@otrs.org>
  • GPG Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

  • ID: OSA-2022-05
  • Date: 2022-03-21
  • Title: Possible XSS attack via translation
  • Severity: 3.5 LOW
  • Product: OTRS 7.0.x, OTRS 8.0.x
  • Fixed in: OTRS 7.0.33, OTRS 8.0.20
  • FULL CVSS v3.1 VECTOR: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
  • References: CVE-2022-0475

OSA-2022-05 Possible XSS attack via translation (CVE-2022-0475)

PRODUCT AFFECTED:

This issue affects OTRS 7.0.x and OTRS 8.0.x.

PROBLEM:

Malicious translator is able to inject JavaScript code in few translatable strings (where HTML is allowed). The code could be executed in the Package manager.

This issue affects:

OTRS AG OTRS 7.0.x version 7.0.32 and prior versions, OTRS 8.0.x version 8.0.19 and prior versions.

This issue was found during internal product security testing or research.

This issue has been assigned CVE-2022-0475.

SOLUTION:

Update to OTRS 7.0.33 and OTRS 8.0.20.

MODIFICATION HISTORY:

  • 2022-03-21: Initial Publication.

CVSS SCORE:

3.5 (CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N)

RISK LEVEL:

LOW

ACKNOWLEDGEMENTS:

Special thanks to Balázs Úr for reporting these vulnerability.

Release Details

  • Release name:
    OTRS Security Advisory 2022-05
  • Release date:
    03/21/2022
  • Release type:
    security advisories