OTRS Survey 8 Patch Level 4

Release Note

OTRS Survey 8 Patch Level 4

October 18, 2021 — OTRS Group, the world’s leading provider of the OTRS service management suite, including the fully managed OTRS solution and the ITIL® 4-compliant IT service management software OTRS::ITSM, today announces the first release of the OTRS Survey module 8 patch level 4.

 

What’s New

Bug Fixes

  • Ticket#2021030542001027 – Error message “Use of uninitialized value $Row[3]” on Maint::Survey::RequestsDelete

Browser Support

  • JavaScript is required to use OTRS.

These browsers are not supported:

  • Microsoft Internet Explorer before version 11
  • Firefox before version 31
  • Safari before version 6

We recommend to use the latest version of your browser, because it has the best JavaScript and rendering performance. Dramatical performance varieties between the used browsers can occur with big data or big systems. We are happy to consult you on that matter.

Note:

  • OTRS 9 will not support Internet Explorer anymore.
  • OTRS 9 will not support Oracle as application database anymore.

 

OTRS Group managed customers who are using product versions that are reaching end of maintenance and support must be updated by our Customer Solution Team by scheduling an individual maintenance appointment in order to continue receiving necessary releases and support. OTRS On-Premise customers must obtain a newer product version by ordering our migration services.

Please note that from now on we will only officially support OTRS 7 and OTRS 8 for regular maintenance. The last supported versions for security fixes are OTRS 7 and OTRS 8.

Release Details

  • Release name:
    OTRS Survey 8 Patch Level 4
  • Release date:
    18. October 2021
  • Release type:
    patch level
  • Required OTRS release:
    OTRS 8 Patch Level 13